Plesk

License key automatically terminated [Troubleshooting]

Symptoms

Plesk license key get terminated automatically in Plesk panel in spite of the fact that the license is valid.

Cause

Plesk license can key get terminated automatically in Plesk panel if the daily maintenance script is unable to be executed properly or if the server is unable to communicate with
ka.plesk.com

Resolution

  1. Check the connectivity of the server to
    ka.plesk.com
    using this article:
    License fails to update
  2. Check that
    Retrieve Keys
    button is giving correct output:

    Key Update Status
    License key PLSK.01234567.0000! is up-to-date.
  3. Make sure that if you Update key manually by running the Daily Maintenance script, it is completed with no errors:

    /usr/local/psa/bin/sw-engine-pleskrun /usr/local/psa/admin/plib/DailyMaintainance/script.php -f UpdateKeys
  4. If none of the steps above helped you to find out the cause of the issue, check the KB article below:

    How to get technical support for Plesk?

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