Plesk

FTP access error: 530-User cannot log in, home directory inaccessible

Symptoms

Cause

Misconfiguration of the FTP websites and FTP users.

Resolution

  1. Log into the server via RDP.

  2. Execute the following command via the command line:

    plesk repair ftp -y

    Note: There is a probability, that the issue is resolved completely by this command. Check FTP access once again. In case the issue will persist, proceed further with the resolution.

  3. Execute the following command via the command line in order to re-create the FTP site and users in IIS:

For one domain

"%plesk_cli%repair.exe" --reconfigure-ftp-site -webspace-name example.com

"%plesk_cli%repair.exe" --repair-webspace-system-users -webspace-name example.com

For all domains

  1. Reconfigure an FTP service for all domains in PowerShell using these two commands:

    PS plesk bin subscription -l | % { if ($) { plesk bin repair --reconfigure-ftp-site -webspace-name $ } }

    PS plesk bin subscription -l | % { if ($) { plesk bin repair --repair-webspace-system-users -webspace-name $ } }

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