Symptoms
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The following error can be found in the Plesk Home page after the failed ModSecurity update:
Error: Failed to update the ModSecurity rule set. Details
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In the menu Tools & Settings > Web Application Firewall (ModSecurity) the following error can be found:
Error: Failed to update the ModSecurity rule set: modsecurity_ctl failed: gpg: key 4520AFA9: "Atomicorp (Atomicorp Official Signing Key) [email protected]" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
gpg: Signature made Thu Mar 15 01:24:49 2018 +07 using RSA key ID 4520AFA9
gpg: Good signature from "Atomicorp (Atomicorp Official Signing Key) [email protected]"
gpg: WARNING: This key is not certified with a trusted signature!
gpg: There is no indication that the signature belongs to the owner.
Primary key fingerprint: 1818 66DF 9DAC A40E 5B42 9B08 FFBD 5D0A 4520 AFA9
TERM environment variable not set.
aum failed with exitcode 3.Or
Error: Failed to update the ModSecurity rule set: modsecurity_ctl failed: gpg: key 4520AFA9: "Atomicorp (Atomicorp Official Signing Key) [email protected]" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
gpg: Signature made Mon Apr 15 18:15:00 2019 CEST using RSA key ID 4520AFA9
gpg: Good signature from "Atomicorp (Atomicorp Official Signing Key) [email protected]"
gpg: WARNING: This key is not certified with a trusted signature!
gpg: There is no indication that the signature belongs to the owner.
Primary key fingerprint: 1818 66DF 9DAC A40E 5B42 9B08 FFBD 5D0A 4520 AFA9
TERM environment variable not set.
aum failed with exitcode 3.
stdout:
Checking versions ...
AUM version is current: package asl is not installed[75G[[1;31m[1;32mPASS[0m[0m]
Authorization failed attempting to download an update.
The username or password may be invalid, or your license may be expired.
Please log in to the License Manager at https://www.atomicorp.com/amember/member.php and verify your account.
Further information may be found at: https://www.atomicorp.com/wiki/index.php/ASL_FAQ#HTTP_Error_401:_Authorization_Required.
-------------------------------------------------------------------------------
Errors were encountered:
L CODE SOURCE MESSAGE-
---- ----------------------------- ------------------------------------------
[1;31m3 303 Core::distributed_update Invalid user credentials
[0m159.69.178.159
203.0.113.2
stderr:
Unable to download tortix rule setOr
Error: Failed to update the ModSecurity rule set: modsecuritymng failed: Error sending request 'channels/rules/plesk/modsec-201905100838.tar.bz2' to 'updates.atomicorp.com': status 401
at (WebRequest::executeRequest line 122)
at executeRequest(updates.atomicorp.com/channels/rules/plesk/modsec-201905100838.tar.bz2)(WebRequest::executeRequest line 127)
at downloadFile(updates.atomicorp.com/channels/rules/plesk/modsec-201905100838.tar.bz2)(WebRequest::downloadFile line 145)
at download(C:Program Files (x86)PleskPrivateTemp460E7B5.tmp)(ModSecurity::TortixRuleSet::download line 90)
at installRuleSet(tortix, )(ModSecurity::Adapter::installRuleSet line 62)
at installRuleSet(tortix, , true)(ModSecurityManager::installRuleSet line 47)
at execute console command --install-ruleset(vconsoleapp::start line 93)
at execute "C:Program Files (x86)Pleskadminbinmodsecuritymng" --install-ruleset --with-backup "--ruleset=tortix"(vconsoleapp::run line 110)
(Error code 1) -
While trying to login to Atomicorp account using credentials from the
/etc/asl/config
file, the error as following can be seen:The user name or password is incorrect
Cause
Temporary issue on the Atomicorp side.
Resolution
A few hours after facing the error, follow the steps below: