Symptoms
- Emails go to the Spam folder instead of the Inbox folder when the DKIM spam protection is enabled for the domain in Plesk > Domains > example.com > Mail Settings > Use DKIM spam protection system to sign outgoing email messages.
- DKIM is marked as Fail in by email services, for example, Gmail or Hotmail.
Cause
DKIM record is corrupted.
Resolution
- Log into Plesk
- Go to Domains > example.com > Mail Settings.
- Disable the Use DKIM spam protection system to sign outgoing email messages option.
- Press the Apply button.
- Enable the Use DKIM spam protection system to sign outgoing email messages option.
- Press the OK to button to generate a new DKIM record.
Note: on Plesk for Windows the DKIM record is recreated instead of regenerating, this is enough for the case when the DKIM record is broken.
Note: is DNS is hosted externally, manually copy default._domainkey.example.com record to the external DNS server