Plesk

Emails from certain domain moved to SPAM folder on a Plesk server when DMARC is enabled

Symptoms

  1. Email messages from example.com are moved to the SPAM folder.
  2. Email headers contain the following:

    Return-Path: RTE+NE-null-b1cb1A034703828DQF3BWI0IXL@ sellernotifications.example.com 
    [...]
    dmarc=fail (p=QUARANTINE sp=NONE) d= sellernotifications.example.com ; header.from= example.com  ;
    [...]
    From: Domain do-not-reply@ example.com

Cause

A mismatch between "Return-Path" and "From" domains in email headers from example.com. DMARC requires a domain name to match in both headers.

Resolution

Whitelist example.com:

  1. Connect to the server via SSH;

  2. Add the following to the /etc/psa/dmarc.conf using any text editor:

    IgnoreMailFrom example.com
    ## IgnoreMailFrom domain[,...]
    ## default (none)
    ## Gives a list of domain names whose mail (based on the From: domain) is to
    ## be ignored by the filter. The list should be comma-separated. Matching
    ## against this list is case-insensitive. The default is an empty list,
    ## meaning no mail is ignored.

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