Symptoms
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Analyzing an email header sent from plesk with MXToolbox or similar shown the following error on the report:
SPF Authentication : SPF Failed for IP - 127.0.0.1
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The email was sent from Plesk using webmail.
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Full header does show the Plesk Server IP on the first
Received: from
line:Received: from plesk-hostname.example.com(unknown [203.0.113.2])
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Same header reports a correct SPF result of
pass
:Authentication-Results server.hostname.plesk; spf=pass (sender IP is 127.0.0.1) [email protected] smtp.helo=plesk-hostname.example.com
Received-SPF pass (plesk-hostname.example.com: localhost is always allowed.) client-ip=127.0.0.1; [email protected]; helo=plesk-hostname.example.com;
Cause
This is expected for emails sent from the webmail, 127.0.0.1 is added to the email headers. While sending email from email client will show the client IP instead. Additionally, if Plesk Email Security is installed, Amavis service may add the localhost when it scans the email passed from Postfix.
Resolution
The SPF result is pass
so no actions are required. localhost IP failed message can be safely ignored.