Symptoms
-
The website example.com (or webmail webmail.example.com) shows incorrect content in web browser or it is not accessible:
ERR_NAME_NOT_RESOLVED
OR
This site can’t be reached
-
The nslookup utility can't find domain or webmail name:
# nslookup example.com 8.8.8.8
Server: 8.8.8.8
Address: 8.8.8.8#53** server can't find example.com: NXDOMAIN
# nslookup webmail.example.com
Server: 8.8.8.8
Address: 8.8.8.8#53** server can't find webmail.example.com: NXDOMAIN
-
A DNS record presents on the name server where DNS "example.com" zone is hosted:
# nslookup example.com 203.0.113.2
Server: 203.0.113.2
Address: 203.0.113.2#53Non-authoritative answer:
Name: example.com
Address: 203.0.113.2 -
NS records have been changed recently.
- Incorrect certificate is showing for domain
Cause
Domain name cannot be resolved into correct IP address.
Resolution
- Log in to Plesk
- Go to Domains > example.com and determine IP address assigned to the domain:
- Log in to DNS management panel of registrar company, example.com name was purchased from.
-
Create/update NS-record for example.com pointing to the actual Plesk IP address.
- Wait until DNS update propagation is finished. This process can take 24 to 48 hours.