Symptoms
- Domain log viewer in Domains > example.com > Logs continues loading indefinitely until a timeout error appears
- In some cases, the following error may appear
Maximum execution time of 600 seconds exceeded (PhpFopen.php:106)
- Node.js is installed on the domain and its logs are enabled
- Increasing the timeout just leads to endless loading
- Logs are >100MB
Cause
Product issues:
#PPPM-13826 "Timeout when opening Logs menu in the website dashboard"
#PPPM-14003 "Passenger writes excessive logs"
Resolution
It will be addressed in future Plesk updates and can be tracked in the Change Log.
As a workaround, Node.js logs can be disabled by editing panel.ini and adding the following section:
[ext-nodejs]
showApplicationLogs = false