Symptoms
- Default Plesk web page or other incorrect web page is shown when example.com is opened in web browser instead of the desired web page
- On opening the complete URL to the website in webbrowser, for example
https://example.com/index.php
orhttps://example.com/Default.aspx
the correct website is shown
Cause
A different document is processed before the desired Index file
on Plesk for Linux or Default document
on Plesk for Windows.
Resolution
Note: The desired index file (Linux) or default document (Windows) depends on the website application. To find the correct filename, contact the website developer.
Change index file load order:
For Plesk for Linux
- Log into Plesk
- Go to Domains > example.com > Apache & Nginx Settings
- Enable checkbox Enter values for Index files
- Remove the line with unwanted document from the list, or place the desired index filename to the first line
- Click OK
For Plesk for Windows
- Log into Plesk
- Go to Domains > example.com > IIS Settings
- Enable checkbox Enter values for Default documents
- Remove the line which is not the default document filename from the list, or place the desired default document filename to the first line
- Click OK
Alternatively, remove unwanted document which is not the Index file or Default document in website's document root:
- Log into Plesk
- Go to Domains > example.com > File Manager
- Open domain's document root directory, for example folder
httpdocs
- Rename or delete the incorrect file which is served before the desired document, for example the file
index.html
: