Plesk

Constant email notification about the expiration of previous version of Plesk license key

Symptoms

  1. Plesk administrator receives email notification every day:

    Unable to update PLSK.12345678.0005: an error occurred while processing your key.
    You can try to retrieve the key manually in Plesk (Tools & Settings > License Management) or let Plesk try to update it in the next 24 hours. If you do not want to receive this notification any more, remove this key from Plesk.
    The license key is expired. Some features can be unavailable. Please contact your hosting provider.

    However, current Plesk license at Tools & Settings > License Management is PLSK.12345678.0006.

  2. Error in /var/log/plesk/panel.log

    ERR [1] error: Cannot find a key with ID "EXT.12345678.0005"
    ERR [panel] Unable to read additional key info: :
    0: /usr/local/psa/admin/plib/Key/Additional.php:32
            Key_Additional->__construct(string 'EXT.12345678.0000')
    1: /usr/local/psa/admin/htdocs/server/additional_key_info.php:21

Cause

Obsolete key version in registry.xml or /etc/sw/keys/keys/key* file.

Resolution

  1. Log in to Plesk via SSH
  2. Find the file which contains the key version mentioned in the error message:

    # grep -ri 0005 /etc/sw/keys/
    /etc/sw/keys/keys/keyXXd4E5F6: <core:key-version core:type="string">0005</core:key-version>
    /etc/sw/keys/registry.xml:<member><name>PLSK.12345678.0005</name>

  3. Move the found file to the
    /etc/sw/keys/backup/
    directory:

    # mv /etc/sw/keys/keys/keyXXd4E5F6 /etc/sw/keys/backup/

  4. Remove the
    /etc/sw/keys/registry.xml
    file and recreate it by logging out and logging back in to Plesk.
  5. Go to Tools & Settings > Licence Management and click Retrieve Keys.
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