Skip to content
  • Solutions
    By Role
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    By Infrastructure
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
  • Product
    • Plesk Features
    • Plesk Editions
    • What’s new
    • Pricing
    • Roadmap
    • Lifecycle Policy
    • Extensions Catalogue
  • Pricing
  • Extensions
    Featured Extensions
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    Bundles and packs:
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack

    See all Extensions

  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
Plesk 360 login
Free Trial

Knowledge Base

Can’t back up Plesk with Acronis Backup: version `GLIBCXX_3.4.26′ not found

 
acronisacronis backupacronis backup extensionapplications extensionsbackup

Symptoms

  • After updating Plesk Obsidian to version 18.0.40, Acronis backup fails with the following error:

    Failed to execute command '/usr/lib/Acronis/BackupAndRecovery/webcpprecapture: /usr/bin/sw-engine: /usr/lib/Acronis/system_libs/8.2.1/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by /usr/bin/sw-engine)

  • Acronis console shows the following error message:

    Cannot protect a device with assigned quota
    Protection plan 'webcp' has been revoked from 'server.example.com' due to a licensing issue.

Cause

A bug in the Acronis agent that has been fixed in version 15.0 28610.

Resolution

Update the Acronis Agent (Recommended)
Manual Workaround

   

   

  1. Log in to Plesk

  2. Open Acronis Backup > Go to backup console (it may ask for credentials)

  3. Go to Settings > Agents in the Acronis Backup console

  4. Select the machines with an outdated agent. They're marked with an orange exclamation mark.

    Note: The machines must be online.

  5. Click Update agent

Make sure all previously configured directives are set: 69808: Acronis Backup extension for Plesk: Backup fails after Plesk update to version 18.0.40:

2.png

   

   

   

  1. Connect to the Plesk server over SSH

  2. Edit /usr/lib/Acronis/BackupAndRecovery/webcpprecapture

    # vi /usr/lib/Acronis/BackupAndRecovery/webcpprecapture

  3. Add the following lines:

    unset LD_LIBRARY_PATH
    unset LD_PRELOAD

  4. Save the changes

If the Acronis agent is on version 28323 (can be checked in Acronis console), follow these steps too:

  1. Connect to the Plesk server over SSH

  2. Download the patched libwebcp_agent.so

    # wget https://plesk.zendesk.com/hc/article_attachments/12376927359895/libwebcp_agent.so

  3. Rename the original file:

    # mv /usr/lib/Acronis/BackupAndRecovery/libwebcp_agent.so{,.backup}

  4. Move the downloaded file to the Acronis directory:

    # mv libwebcp_agent.so /usr/lib/Acronis/BackupAndRecovery

  5. Restart the Acronis service:

    # service acronis_mms restart

  6. Verify that Plesk is detected:

    Note: It make take a couple of minutes to take effect.

    # acropsh -m dmldump -s mms -vs InstanceManagement::Instance | grep InstalledApplication

    ('.Parameters.InstalledApplication', 'item_string', 'Plesk'),
    ('.Parameters.InstalledApplication^Searchable', 'nil', None),

   

Tweet
Share
Share
Email
0 Shares
Read the full article
Related Posts

You Are Always Safe When You Have an Up-To-Date Plesk Backup

Read More »

The Plesk HoliDeals Calendar is here (Part 2)

Read More »

Get Your Hands on Plesk Extensions and Toolkits This ‘HoliDeals’ Season (Part 1)

Read More »
Knowledge Base

Some operations in Acronis Backup extension in Plesk fail: Declaration of Modules_AcronisBackup_OperationsListAdapter::count() must be compatible with CommonPanel_View_List_Paginator_Array::count(): int

Read More »

Creating backup in Acronis Backup extension in Plesk fails: The SnapAPI kernel module is not loaded for the kernel

Read More »

Unable to access Acronis Backup extension in Plesk: An error has occurred. Please try again later or contact support

Read More »

 An operation fails in Plesk: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry ‘X’ for key ‘PRIMARY’

Read More »

Hosting Wiki

  • Django
  • RESTful Web Service
  • Server Redundancy
  • Cloud Service Architecture
  • Virtualizor
  • On-Demand Services
  • Google Cloud CDN
  • AMP
  • Bare Metal Server
  • Backup
  • Denial of Service
  • Red Hat Virtualization
  • Virtuozzo
  • Oracle VM Server
  • Citrix Hypervisor
  • Server Virtualization Software
  • Windows Server
  • Linux
  • Virtualization
  • MongoDB
  • VirtualMin
  • Plesk
  • Web Server
  • DNS Server
  • SSH
  • Email Virus Protection
  • HTTP
X-twitter Linkedin Youtube Reddit Github
  • Product
  • Login
  • Pricing
  • Editions
  • For Partners
  • Partner Program
  • Contributor Program
  • Affiliate Program
  • Plesk University
  • Company
  • Blog
  • Careers
  • Events
  • About Plesk
  • Our Brand
  • Resources
  • User and Admin guides
  • Help Center
  • Migrate to Plesk
  • Contact Us
  • Hosting Wiki
  • Forum
  • Legal
  • Legal
  • Privacy Policy
  • Imprint

© 2025 WebPros International GmbH

Part of the WebPros®  Family