Plesk

Cannot start PleskSQLServer service: System error 1058 has occurred. The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

Symptoms

Cause

Plesk SQL Server service configuration has been corrupted during the update.

Resolution

  1. Connect to the server via RDP

  2. Start a command prompt as Administrator

  3. Stop the PleskSQLServer service:

    C:> net stop PleskSQLServer

  4. Delete the PleskSQLServer service:

    C:> sc delete PleskSQLServer

  5. Re-create the PleskSQLServer service:

    C:> sc create PleskSQLServer start= auto DisplayName= "Plesk SQL Server" binPath= ""%plesk_dir%MySQLbinmysqld.exe" --defaults-file="%plesk_dir%MySQLmy.ini" PleskSQLServer"

  6. Configure the Log on user in the PleskSQLServer service:

    C:> sc config "PleskSQLServer" obj= "NT ServicePleskSQLServer"

  7. Start the PleskSQLServer service:

    C:> net start PleskSQLServer

  8. Continue with the upgrade of Plesk with the following command and selecting forward options:

    C:> plesk installer --console --debug

Note: The following warning might appear during the upgrade, but can be safely ignored:

Continuing with the upgrade without having an appropriate product license key will result in the installation of a default license key with limited functionality. Administrators are advised to first acquire the appropriate license key before continuing with the product upgrade.

Exit mobile version