Plesk

Cannot send emails: 450 4.7.1 Client host rejected: cannot find your hostname

Symptoms

Cause

Incorrect or missing PTR record of the sender's mail server.

Resolution

Contact the server hoster or provider of the IP address in order to correct PTR record and make it pointing to the mail server hostname. For Plesk hosted on Cloud server, follow the article below:

How to add PTR record to Cloud Server with installed Plesk?

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