Symptoms
-
Bounce email message is received with following information:
your rDNS doesn't match with domain sending mail
You IP address 203.0.113.2 is associated to domain mail.example.com.
Howerver, your email has been sent from example.org.
Maybe you might want to change DNS (PTR type) and your server hostname to same value.
Here values used to make this test:
IP: 203.0.113.2
HELO: example.org
rDNS: mail.example.com -
SMTP HELO greeting contains the Plesk hostname, which is configured in Tools & Settings > Server Settings > Full hostname:
example.org
-
Sender domain
example.com
is hosted in Plesk and resolves to following IP address:# dig @8.8.8.8 example.com +short
203.0.113.2 -
PTR record for
example.com
IP resolves tomail.example.com
:# dig @8.8.8.8 -x 203.0.113.2 +short
mail.example.com.
- Tools & Settings > Mail Server Settings > Outgoing mail mode is set to Send from domain IP addresses
Cause
Plesk is configured to use Plesk hostname for SMTP greeting, therefore rDNS lookup on sender IP doesn't match because it resolves to a different domain.
Resolution
Warning: Selecting this option may result in mail sent from some or all domains being marked as spam if the destination mail server uses cbl and more than one domain on the Plesk server uses the same IP address.
- Login into Plesk
- Go to Tools & Settings > Mail Server Settings
- Set Outgoing mail mode option to Send from domain IP addresses and use domain names in SMTP greeting and click OK to apply changes.