Symptoms
- Backup restoration finished with a warning:
Restoration of the backup 31 / May / 2018 22.34 completed, but some problems have occurred to restore. Download log file View log Close this message.
- In the downloaded log file the following error is shown :
WARNING: (Restore hosting object 'example.com') Can not deploy content of domain example.com
WARNING: () Archive error: Unable to extract files from /var/lib/psa/dumps/domains/example.com/backup_user-data_1805312234.tgz to /var/www/vhosts/example.com: /usr/lib/plesk-9.0/sw-tar: bin/head: Cannot open: File exists
/usr/lib/plesk-9.0/sw-tar: bin/vi: Cannot open: File exists
/usr/lib/plesk-9.0/sw-tar: bin/rmdir: Cannot open: File exists
/usr/lib/plesk-9.0/sw-tar: bin/wget: Cannot open: File exists
/usr/lib/plesk-9.0/sw-tar: bin/mkdir: Cannot open: File exists
[...] - The domain has Scheduled tasks, which are included in the backup;
- In Domains > example.com > Web Hosting Access > Access to the server over SSH is set to Forbidden.
- In Tools & Settings > Scheduled Tasks > Settings, shell is set to /bin/bash (chrooted).
Cause
Product issue:
-
#PPPM-9283 "When restoring a subscription with scheduled tasks from a backup, users no longer see the warning “usr/bin/bash: Cannot open: File exists”."
Fixed in:- Plesk Onyx 17.8 01 October 2018 (Linux)
Resolution
Workaround
If update is not possible for some reason you may try the following
temporary solution
This warning may be safely ignored since all files are restored.