Skip to content
  • Solutions
    By Role
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    By Infrastructure
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
  • Product
    • Plesk Features
    • Plesk Editions
    • What’s new
    • Pricing
    • Roadmap
    • Lifecycle Policy
    • Extensions Catalogue
  • Pricing
  • Extensions
    Featured Extensions
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    Bundles and packs:
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack

    See all Extensions

  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
Plesk 360 login
Free Trial

Knowledge Base

After removing a WordPress domain in Plesk WP Toolkit starts to show an error: Can not find domain by id X

 
applications extensionsbackupdatabaseemailhttps

Symptoms

  • After removing a domain with a WordPress instance, an error message starts to appear on the Plesk Panel:

    Can not find domain by id 123

  • Email notifications from Plesk may be received by domain owners about application updates:

    Updates were not installed for the following items:
    1. Instance "My Instance Name" (https://example.com): Can not find domain by id 123

  • An attempt to remove a plugin from another WordPress instance fails with:

    Installation "example": Can not find domain by id 123"

  • The following records can be found in the Plesk log files /var/log/plesk/panel.log on Linux or %plesk_dir%adminlogsphp_error.log on Windows Server:

    Failed to generate screenshot of instance #5: URL of instance #5 is empty
    ERR [extension/wp-toolkit] Can not find domain by id 123

  • Unable to remove WordPress instance via Applications. The following message is returned on a blank page:

    {"status":"success"}

  • The WordPress instance files were manually from /var/www/vhosts/example.com/httpdocs.

Cause

Orphaned data in WordPress SQLite database for the removed domain

Resolution

Apply the corresponding steps:

For Plesk on Linux Server

  1. Connect to the Plesk server via SSH.

  2. Create a backup dump of the 'psa' database.

  3. Remove any possible tasks leftover from the Plesk database:

    # plesk db "truncate longtasks"
    # plesk db "truncate longtaskparams"

  4. Create a backup of the WP Toolkit database:

    # cp -p /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3{,.backup}

  5. Access the WP Toolkit database in SQLite:

    # sqlite3 /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3

  6. Enable headers:

    # sqlite> .headers on

  7. Get a WordPress instance ID using the domain ID from the error message. In this example, domainId is 123:

    # sqlite> select Id from Instances where domainId=123;
    id
    567

  8. Remove all corresponding information:

    sqlite> DELETE FROM InstanceProperties WHERE instanceId=567;
    sqlite> DELETE FROM InstancesDomains WHERE instanceId=567;
    sqlite> DELETE FROM Instances where id=567;

    Note: If more than one instance id was listed on the previous step output, execute the above InstanceProperties, InstanceDomains and Insntances deletions for each ID number accordingly.

  9. Exit SQLite:

    # sqlite> .quit

For Plesk on Windows Server

  1. Connect to the Plesk server via RDP.

  2. Download the command tool for managing SQLite databases and extract sqlite3.exe into %plesk_dir%varmoduleswp-toolkit.

  3. Create a backup of the 'psa' database.

  4. Open a command prompt (CMD) as Administrator and remove possible tasks leftovers from the Plesk database:

    C:> plesk db "truncate longtasks"
    C:> plesk db "truncate longtaskparams"

  5. Create a backup copy of the WP Toolkit database:

    C:> copy "%plesk_dir%varmoduleswp-toolkitwp-toolkit.sqlite3" "%plesk_dir%varmoduleswp-toolkitwp-toolkit.sqlite3.bak"

  6. Open the downloaded tool and access the WP Toolkit database:

    C:> "%plesk_dir%varmoduleswp-toolkitsqlite3.exe" "%plesk_dir%varmoduleswp-toolkitwp-toolkit.sqlite3"

  7. Enable headers:

    sqlite> .headers on

  8. Get a WordPress instance ID using the domain ID from the error message. In this example, domainId is 123:

    sqlite> select instanceId from Instances where domainId=123;
    instanceId
    567

  9. Remove all corresponding information leftovers:

    sqlite> DELETE FROM InstanceProperties WHERE instanceId=567;
    sqlite> DELETE FROM InstancesDomains WHERE instanceId=567;
    sqlite> DELETE FROM Instances where id=567;

    Note: If more…

Tweet
Share
Share
Email
0 Shares
Read the full article
Related Posts

You Are Always Safe When You Have an Up-To-Date Plesk Backup

Read More »

Plesk with Centralized Database and Network File System

Read More »

Advanced Techniques for Building an Email List

Read More »
Knowledge Base

WP Toolkit Cloning hangs or stops after 60 seconds on a Plesk server

Read More »

Duplicate entries in Plesk WP Toolkit: nginx: [emerg] duplicate location “/fake-hotlink-stub”

Read More »

Unable to clone WordPress instance in WP Toolkit : PHP Fatal error: Uncaught Error: Class “WP_Upgrader_Skin” not found

Read More »

Can’t install plugin via WP Toolkit: destination folder already exists

Read More »

Hosting Wiki

  • Server Redundancy
  • Linux Containers
  • AMP
  • Bare Metal Server
  • Backup
  • Oracle VM Server
  • Server Virtualization Software
  • Windows Server
  • Linux
  • Joomla! Toolkit
  • WP Toolkit
  • WordPress
  • Plesk
  • SQL database
  • NoSQL Database
  • Web Server
  • DNS Server
  • SSH
  • URL
  • Email Autoresponder
  • Email Alias
  • Email Virus Protection
  • Email Forwarding
  • HTTP
X-twitter Linkedin Youtube Reddit Github
  • Product
  • Login
  • Pricing
  • Editions
  • For Partners
  • Partner Program
  • Contributor Program
  • Affiliate Program
  • Plesk University
  • Company
  • Blog
  • Careers
  • Events
  • About Plesk
  • Our Brand
  • Resources
  • User and Admin guides
  • Help Center
  • Migrate to Plesk
  • Contact Us
  • Hosting Wiki
  • Forum
  • Legal
  • Legal
  • Privacy Policy
  • Imprint

© 2025 WebPros International GmbH

Part of the WebPros®  Family